CNCフライス(13) Windows10ラップトップ + Mach3

公開: 2020/10/24
Mach3関連他追記:2020/10/31

直前の記事でも書いたようにWindows10でもMach3が動くのと、ラップトップでもUC100を使って機械を動かせるということで、脱XP(+LPT)のためにダメ元で中古の東芝ダイナブックを手に入れました。
注文して3日くらいで届きましたが、Windowsって変わってないな〜と思いながら設定などしていると、エラーメッセージが出ました;

OKを押しても何分かすると現れて、だんだん頻度が高くなってきました。

今まで新品・中古に限らずコンピュータ関係で外れを引いたことはなかったので、とうとう運も使い果たしたかなと買ったサイトへ状況を連絡したんですが、あいにく土曜日で月曜まで返事は来ません。
裏側の冷却ファン排気のスリットをよく見たらどうもファンが回っていないようで、細い電線で突っついてみたら回りだしました。
その後エラーは出なくなって、運はもうちょっと残ってるみたいです。

実装メモリ4GBでは心許ないので、空いてるスロットに増設しました。
(DDR3L 1600 PC3L-12800 4GB)
『お客様ではメモリの交換・増設はできません』となっていますが、裏蓋の20数本のネジに挑戦すれば簡単にできます。バッテリ側ヒンジ部の左右各2本、計4本のネジが少し長く、他のネジはすべて同じです。
写真を撮り忘れたんですが、詳しくはこのサイトで ==> 
裏蓋を開けたときにエアダスタで吹いてみるとファンのあたりからホコリが飛んでいきました。

一件落着で、XPのデスクトップから抜き出したMach3フォルダの全ファイルをコピー、念のためArtSoftからMach3をダウンロードしてインストールしました。
Windows10用パッチファイルというのも実行しましたが、特に変化は無くMach3は正常に立ち上がりました。
*文末に追記
アプリのプロパティからWindowsXP互換モードにするとタイトルバーの色がXPとほぼ同じになりました。
ところが、ペンダント代わりのUSBテンキーパッドのカスタマイズ(AutoHotKey)がファイルをコピーした時点では正常だったんですが、いつの間にか(?)各軸を動かせるだけで作業タブの切り替えなどができなくなりました。
AutoHotKeyのスクリプトを実行していないようで、ネットで調べていろいろ試してみましたが解決できず、ヘコんでいます。

案外簡単な理由かも知れませんが …. 
次の記事の通り、やはり簡単な理由でした

ディスプレイは横長1366×768で、縦サイズが合っているのにMach3ウィンドウ(1024×768)の下端がわずかに切れます。
Mach3標準スクリーンセット(1024.set)は余裕で表示されるので、2010Screensetの問題みたいです。
ディスプレイ設定を1024×768にしたら解決するんですが、デスクトップが見えるようにしたいので悩ましいところです。

Mach3に限らずフォントがかすれたように汚くて、最新でないにしても4年前のPCでこれはないやろとがっかりでしたが、ClearTypeテキストに設定するとマシになりました。なぜ初めから設定しておかないのかと不思議です。
また、起動時にログイン画面の前にロック画面が表示され時間がかかるので、表示無しにしたら早くなりました。
さらに、自動ログインにするともっと早くなるかもと設定したら、思いっきり遅くなったのでやめました。

何か設定を変えようとするとディスク内を探し回ってとてもイライラしますね。
直感と合わないことが多くて動作も重く、解説本がいっぱい出ているのが分かる気がします。
頭の体操には良いかもしれませんが、スマートじゃないです。

まぁそこらは置いといて、
UC100はメーカーサイトからプラグインなどをインストールして、実際の加工が問題なくできることを確認し、自分のシステムはこうなりました;
CAD(MacBook) => ファイル共有 iCloud Drive => DynaBook
=> VCarvePro Gコード作成、Mach3読込
=> UC100 USB/DSUB25 => HobbyCNC Pro => 自作機

その後、iCloud Drive をWindows側からアクセスできるようにして、MacBookからDXFファイルを書き込むようにしました。
ファイル共有は相手のコンピュータが起動していないとダメですが、iCloud Drive なら気にせずにファイルやデータを放り込んでおけます。

2020/10/31 追記:
Mach3フォーラムのWindows10でエラーが出るという投稿に、Newfangled Solutions Helpdesk から「インストーラには対応するパッチを当てた」というコメントがあったのを見落としていました。
There is a new Mach3 installer on our website (machsupport.com) that includes a patched version of .062 that corrects this issue. Install it over your previous version of Mach3, restart, and you should be back to normal. As always, I recommend backing up your profile, license, and any custom macros or screens–just in case.
« Last Edit: May 17, 2018, 02:19:54 AM by bryannab »

ダウンロードしたMach3.exeの日付(2018/5/14)と符合しますので、Windows10に換える場合はバージョンにかかわらず、改めてダウンロードするのが安全かと思います。
バージョン1909で問題なく動いています。

/////

 

 

コメントを残す